Dulwich.io dulwich / d6f7940
Drop support for Python 3 < 3.4. This is because pkg_resources (which get used by setuptools and mock) no longer supports 3.3 and earlier. Jelmer Vernooń≥ 1 year, 15 days ago
4 changed file(s) with 6 addition(s) and 13 deletion(s). Raw diff Collapse all Expand all
77 - 3.5
88 - 3.6
99 - 3.6-dev
10 - pypy3.3-5.2-alpha1
1110 - pypy3.5
1211
1312 env:
1716 matrix:
1817 include:
1918 - python: pypy
20 env: TEST_REQUIRE=fastimport
21 - python: 3.3
2219 env: TEST_REQUIRE=fastimport
2320 - python: 3.7
2421 env: TEST_REQUIRE=fastimport
00 0.19.7 UNRELEASED
1
2 CHANGES
3
4 * Drop support for Python 3 < 3.4. This is because
5 pkg_resources (which get used by setuptools and mock)
6 no longer supports 3.3 and earlier. (Jelmer Vernooń≥)
17
28 IMPROVEMENTS
39
88 - PYTHON: "C:\\Python27-x64"
99 PYTHON_VERSION: "2.7.x"
1010 PYTHON_ARCH: "64"
11
12 - PYTHON: "C:\\Python33"
13 PYTHON_VERSION: "3.3.x"
14 PYTHON_ARCH: "32"
15
16 - PYTHON: "C:\\Python33-x64"
17 PYTHON_VERSION: "3.3.x"
18 PYTHON_ARCH: "64"
19 DISTUTILS_USE_SDK: "1"
2011
2112 - PYTHON: "C:\\Python34"
2213 PYTHON_VERSION: "3.4.x"
109109 'Development Status :: 4 - Beta',
110110 'License :: OSI Approved :: Apache Software License',
111111 'Programming Language :: Python :: 2.7',
112 'Programming Language :: Python :: 3.3',
113112 'Programming Language :: Python :: 3.4',
114113 'Programming Language :: Python :: 3.5',
115114 'Programming Language :: Python :: 3.6',