Dulwich.io dulwich / f5905b2
Require at least urllib3, since HTTPResponse.geturl is not available before then. https://github.com/urllib3/urllib3/pull/1382/commits/fc210c543bfb62ae3f1bbbc5d873fa39bd048ff4 Jelmer Vernooń≥ 2 months ago
1 changed file(s) with 2 addition(s) and 2 deletion(s). Raw diff Collapse all Expand all
7676 if has_setuptools:
7777 setup_kwargs['extras_require'] = {
7878 'fastimport': ['fastimport'],
79 'https': ['urllib3[secure]>=1.23'],
79 'https': ['urllib3[secure]>=1.24.1'],
8080 'pgp': ['gpg'],
8181 }
82 setup_kwargs['install_requires'] = ['urllib3>=1.23', 'certifi']
82 setup_kwargs['install_requires'] = ['urllib3>=1.24.1', 'certifi']
8383 setup_kwargs['include_package_data'] = True
8484 setup_kwargs['test_suite'] = 'dulwich.tests.test_suite'
8585 setup_kwargs['tests_require'] = tests_require